Flipper Bricked after trying to update via qFlipper

Hi all,

recently received my flipper zero backed in august 2020,

got a problem with qflipper (1.1.3) update following these instructions under MacOs Monterey 12.4

Don’t know why but the process failed during update and i had to try firmware recovery.

This process failed too and the flipper is now absolutely silent

Now, I’m unable to proceed to the firmware recovery, the flipper don’t detect as DSU in FS mode (tried with W10, ubuntu and MacOs machine without success)

In case of asking :

  • The SD card was a Kingston freshly formatted with the flipper, tried a Sandisk too
  • The flipper was 44% battery during the first firmware update try,
  • I let the flipper charging around 20 minutes before each try to recover the firmware (with a power supply from a RPi4)
  • and “the only thing that works is the little light flashes orange extremely fast after I hold the back arrow and center button” (seem to be in the same case as this post)

No idea what to do now… but i’m really sad after waiting so long, is there another way (GPIO ??) to recover the firmware ?

Are you using any adapters or hubs to connect the flipper to your PC? They are a known issue source, use the most direct connection method possible (preferably with the included USB cable)

I was in direct connection with an usb-c cable, no adapter, no hub

I tried twice just now with the included USB cable and it’s sadly the same, it keep undetected

Hi @Astra, thank’s for your help,

but stil bricked for now despite trying with the provided USB cable suggestion.
is there another way to recover the firmware ? how can I try to save it ?

or if my flipper is definitively down, is there an RMA procedure existing somewhere ?

Sorry for the late reply, I was looking for other possible troubleshooting steps.

In your case yes, you should probably message support@flipperdevices.com and tell them about your issue, they should be able to handle the rest.

So you think there is no other possible troubleshooting way ?
in this case effectively I’ll message the support

Yes, this seems like a hardware problem, according to your description