Family error with all iButtons


Hi all, just wondering if there is any way to surpass the “Family Error” manually. All the iButtons I tried to read seems to have a different family code (not 01). Even tough I inputted manually the showed code, the Flipper is not able to emulate it, nor coping to a new button.

Can you please take a photo of the iButton itself? The round part should have some text, it will help a lot

Hi Astra, thank you for replying. Here is a pic of both the iButton I tried, but neither have any code on the them. Don’t think they give much info. Any ideas on how I can fetch the code and emulate?

Oh, OK those look like the most generic iButtons possible, that doesn’t help :frowning:

Looking at the family code, those probably work differently from the DS1990 that flipper can emulate (the ones with the correct family code), so I’ll message our iButton dev and see what we can do

Thank you @Astra

1 Like

Can you please try to add your key manually: Main Menu → iButton → Add manually → Dallas

Hi @zhovner , thank you for replying. I tried to input the code showed by flipper when reporting the error ( 81FB8C29105003F6, as show in the first pic I posted), but when trying to emulate it, it does not work, as when trying to coping the code on an iButton it doesn’t do it. Should I inputted the code differently, order wise I mean?