Wifi Dev Module issues


I would like to point out a few issues with the Dev Modules.

  1. This documentation (and following pages) is obsolete as of this MR and the migration from make to fbt
  2. The default wifi password for the module is not documented anywhere, I had to spot it on a screeshot in another thread.
  3. Since the migration to fbt there seems to be no way to update the device via the module attached via usb as the monitor command is issued and is not compatible with local debugging targets.

It would be great if these could be fixed!


Thank you for your input! We’re working on updating the docs, so this should be fixed soon.

By the way, you can find the wifi password on the very same page you’ve linked to:

Also, you can flash via the Blackmagic probe using the flash_blackmagic command, documented here

Ok, I am not used to documentation with clickable elements. It’s cute but it really doesn’t make the information easy to find when you expect something linear (which I guess is most people’s expectation).
It is true that flash_blackmagic is documented, but it only works with WiFi (not with the module connected via usb) and even then, the BLACKMAGIC_HOSTNAME variable is a constant and if your router doesn’t call the module blackmagic.local it will fail. It should be overrideable by an environmebt variable (as the BLACKMAGIC one used to do with make)

Thank you for the very fast reply!

It already is customizable on command line and in fbt_options.

# Look for blackmagic probe on serial ports and local network

If you set it to anything that’s not “auto”, it will be passed to gdb as remote instead of trying to find blackmagic device on serial ports & local network.
But, auto-detection of blackmagic’s serial port should also work, and it has higher priority than DNS resolution. If it doesn’t work and you have time for that, we can debug this issue.

I do have time.

Where are the possible values of this variable documented? Why do I have to modify a file that’s is managed by git?

You can copy that file and modify it, then pass your copy to fbt. That’s mentioned in documentation.

## Command-line parameters
- `--options optionfile.py` (default value `fbt_options.py`) - load file with multiple configuration values

Info on BLACKMAGIC parameter is also on the command-line. It might be not that detailed, but since you already found out the hardcoded hostname, you could also notice that this parameter is passed as-is if it’s not “auto”.
Proper docs will be available a bit later, with 1.0 release.

./fbt -h 
BLACKMAGIC: Blackmagic probe location
    default: auto
    actual: auto

Regarding Blackmagic probe lookup, try uncommenting the line below #29, in site_scons/site_tools/blackmagic.py.
# If you're getting any issues with auto lookup, uncomment this

Then re-run blackmagic-related tagets (or just (./fbt get_blackmagic) and share the output.

Also all options settable in fbt_options.py can be passed on command line, ./fbt BLACKMAGIC=COM3, so you don’t have to modify anything at all.

Got it, all very helpful, thank you so much!

I can now do everything with commands like
./fbt flash_blackmagic BLACKMAGIC=tcp:192.168.XXX.YYY:2345

But it is still not working if connected via USB because of the aforementioned use of the monitor monitor gdb command