SD card not working

I just received my flipper and when trying to get it set up, it doesn’t read my SD card. I have a 64 gb sandisk card and it doesn’t detect it. i tried factory resting flipper still doesn’t fix the issue. Any help?

1 Like

Try reformatting the card in Fat32 on your computer. Make sure it doesn’t have multiple partition. You also have to watch out for fake cards. This video gives a good explanation even though it isn’t Flipper related.

1 Like

Many people are complaining about the same even when using true cards and of good brand like sandisk. There is the possibility of a Flipper factory issue / defect related to the sd card socket/connections, etc … So if you have for example a true Sandisk 32Gb card confirmed to work using Fat32 on otrher devices and Flipper doesn’t pick it up most likely it’s a Flipper problem then…

Nope, that’s not the case. We have seen SanDisk clones that are basically indistinguishable from the original cards except for their poor SPI implementation. Every Flipper Zero gets tested at the factory, and any SD slot defects are cathed there. The issue is not with the device, the issue is with the cards.


I have no idea why people are so convinced they didn’t get scammed on the SD cards. Fake SD cards are rampant on Amazon and Amazon won’t do anything about the problem. You need test software to verify if the cards you buy are compliant. They can look extremely convincing on the outside.

Then what do you do to prove the cards wasn’t bad? Buy another from the same seller or pull another one out of the same 2 pack?

There is a case posted here of a guy that did try a huge bunch of cards … not likely for all of them to be bad/fake…

1 Like

I’m sure it happens but an SD card working on a PC gives you no indication whether it will work on the Flipper. The Flipper and PC use SD cards in a completely different mode that some fake cards don’t support.

Have a look at that video I posted above and the problem is explained quite clearly. Those cards he bought had two different issues. We can fix the partitioning issue but can’t fix the SPI problem.