Flipper Zero Low power mode

This topic is dedicated for issues with the new sleep mode for the Flipper Zero.


Hey there! I’m on the official firmware, but when the deep sleep mode is enabled (verified via System > Sleep Method = Default), the Power screen just shows “Consumption is 5mA”, and not “Napping…” like described in this blog post.

Does that mean the Flipper isn’t entering the deep sleep mode? If yes, what can be done to troubleshoot this?


same issue here :slight_smile: quite curious to see what is happening :slight_smile:

1 Like

Disable debuging in settings and try again.

Yeah, the problem is that Debugging prevents the device from going to sleep.


Great insight!

1 Like

Hi, folks!

I’ve got a strange behaviour after upgrading to new firmware — Flipper began to crash & reboot while trying to go to sleep. Ok, I read this topic, went to the settings to make sure that the “debug” mode is turned off. It was.

But why not to try some experiments? I’ve turned it on, then turned it off again and Flipper stopped crashing BUT(!) when I go to Battery Info I’ve got “Om-nom-nom! Consumption is 19 mA”.

OK, let’s go further. I went to settings again & enabled Legacy sleep mode (and then disabled it). Now I’ve got “Napping…”

Maybe it could help somebody.

1 Like

Debug only controls SWD interface and when switched off slightly reduces consumption. We are aware of crashes will issue fix this week.



I’ve tried to have low power mode working with no success so far (8-10 mA consumption, never “napping”)

firmware is 0.83.1 - radio firmware 1.15.0:L

Log level: None
Debug: OFF
Heap Trace: None
Sleep Method: Default

I’ve done the power cycle and waited 10+ seconds
I’ve tried to set log/debug/sleep mode changes and reset them to above
I’ve tried to reflash latest firmware in DFU mode
I’ve tried without an sd card
The bluetooth is OFF

None of these worked and still getting consumption on battery info screen
(I’m waiting until backlight goes off and then some minutes more - still having ~10mA consumption)

Is there anything more I can try to make this working ?

You have mentioned Bluetooth. Is BT on?

Bluetooth is OFF

Please drop a message to support, they’ll guide you throw the diagnostic procedures.

1 Like