Another possible bricked flipper

I’ve searched these forums and have seen several posts like this. I was working on a new app for flipper, compiling and flashing a dfu file to my device as I am testing my code using qFlipper. I had many successful firmware flashes throughout the day. Then, on my last flash attempt, after flashing and while qFlipper was rebooting my device, it hung there in that state for a very long time.

I unplugged the device and attempted all the reboot techniques described in as I have done several times in the past with success. This time, none of them are working.

I’ve seen here in the forums, and I have experienced, that sometimes a particular USB port can just start to “refuse” to recognize flipper. So I tried several different USB ports, on both a mac and windows machine, with direct connections (no hubs), USB C → A and USB C → A → C with no success. I even rebooted my Windows machine to try again, but no luck. I also tried two different USB cables to rule out a faulty cable.

Is there anything else I can try to recover my flipper?


Hi! Let me double-check - did you try entering hardware DFU by holding OK+back for 30 seconds?

Thank you! Yes, I did try that many times to be sure.

Oh, OK, I’ll ask our engineers about your problem and see if we can find some plan of action for this, but they’re probably asleep right now, so I’ll get back to you when I receive an answer.

No worries, it’s the weekend! Thank you for the quick response.

So, first of all, the hardware DFU method doesn’t work if a USB cable is connected to your device. If you still can’t get it to boot - can you please record a video of what you’re doing? Or alternatively, you can tag skotopes#4130 in our discord server and he’ll be able to help you.

Good news, although it drives me crazy: the hardware DFU recovery method worked today. I honestly tried over a dozen times yesterday, in all kinds of ways. I am aware that the USB cable has to be disconnected so that was not the problem. Is it possible for a fat finger touching one of the directional buttons during the 30 seconds hold to cause the method to fail? I know that happened a few times at least, although I tried many more times. Not sure what was going on, but it is working now at least.

1 Like

Glad to hear that! Yes, pressing other buttons during this process may stop it from working, but yeah, sounds weird to me too. Still, nice that everything’s working now :slight_smile: