Universal remote keeps freezing

So I had copied a tv.ir file from github that was bigger than the stock one. Pretty much worked the same with my tv - only the power button did anything. Long story short I copied the code in text editor for volume up and down, and mute from the remote for my tv and pasted them in the tv.ir file in the infared assets folder, hoping they would work with the universal remote. Now for some reason those three buttons freeze my flipper and I have to reboot everytime I try one. I’ve tried removing the codes, removing the file and installing a fresh one, rebooting in dfu mode, reinstalling the firmware and nothing works, it still freezes. Please someone help me figure this out :sob:

Can you please provide the file in question?

Here you go, thank you

I see two problems here. The first one is that the tv database file format was changed recently (4 days ago), and the file you’re using is now outdated. The second one is that the custom file you have might be WAAAAY too big for the flipper to handle (it’s more than 100 times larger). Have you tried reinstalling the stock tv.ir (the one that starts with “Filetype: IR library file”) and adding your codes to it, instead of the custom file?

No I thought of doing that but I wasn’t able to find the stock file :sweat_smile:. I’ll try it now though thanks for the link

You’re welcome :slight_smile:

All the asset files can be found in our firmware repo in the assets folder, btw

1 Like

Everything works! Thanks so much! :pray:t4:

1 Like