Trying to launch NFC breaks app launching

I’m having trouble with my Flipper. Whenever I try to use the NFC reader, it will not launch (no feedback, the center button simply doesn’t do anything). After attempting the launch the NFC reader, none of the other apps will work until I reboot the device. Scrolling through menus works fine, even nested ones like settings and plugins.

The device is new, and was working yesterday perfectly fine. So far I’ve tried doing a factory reset and tried all 3 branches of firmware (currently on release 0.62.1). Nothing has fixed it.

This may be related, but when the NFC was working, it was extremely difficult to read anything. This may be operator error because I’m still learning, but the only thing I’ve gotten it to read is my passport after great difficulty.

Anyone have any ideas? I enabled debug logging but I’m still poking around for the logs.

First of all, did you try other SD cards?

Also, enabling debug logs and the debug mode is not needed and only makes your system less stable, so I’d recommend disabling them.

Thanks for the reply!

I disabled the debug stuff (just thought the logs may be helpful) and swapped SD cards. The first one was a 32GB Sandisk Ultra and the other one I tried was a 2GB Samsung, both from reputable sources. Both benchmarked with similar numbers to the example in the documentation. Both were formatted using the flipper. Still no luck.

Oh, that’s very weird, we’ll have to gather logs.

Have you used flipper’s CLI before? If not, what OS are you using (Windows, macos, Linux etc)?

No, I haven’t. I’m running macos and also have access to a linux box.


Ok, I’m in. (⌐■_■)

Oh, guess you figured it out faster that I was able to send you the manual lol

First, set the log level to Trace in the system settings menu

From there, reboot your device (by holding LEFT+BACK on the Flipper itself), then type log in the cli, and after that, enter the NFC app

After that, copy all the log output to a text file, and send that file here

24744 [I][LoaderSrv]: Starting: NFC
24750 [I][AnimationManager]: Unload animation 'L1_Read_books_128x64'
33693 [E][LoaderSrv]: Loader is locked
36750 [E][LoaderSrv]: Loader is locked

The “loader is locked” messages appeared as I tried to launch the other apps

Hmm, that’s very weird. I’ll contact our dev team and we’ll see what you can do to fix this.

For now, can you try entering your flipper into a DFU mode and re-flashing firmware (the latest dev branch) via qFlipper?

Here’s a docs page on how to do that https://docs.flipperzero.one/basics/firmware-update/firmware-recovery

Did the DFU mode reflash of the dev branch, 6AC1ED2A and tried launching the NFC app again with similar results.

Soo, that might be an issue with a ribbon cable inside of the device. If your open the music player, does the speaker work?

Speaker seems to work fine.

Oh, then the cable is fine, and it seems that the NFC chip itself is not responding. I’m afraid you’ll have get an RMA by messaging support@flipperdevices.com