Sync loop on iOS

Hello, it’s my first post on the Flipper Zero forum so excuse me if I make any mistake.

I was sent here by the Flipper Zero email support team.
The problem I’m having is that every time I add files with my computer to the Flipper Zero when syncing via Bluetooth with my iPhone the app goes into a loop. When I add numerous files it becomes a nightmare to sync.
I think the connection drops when syncing. Then the app reconnects and retries to sync.
Sometimes it reaches 53% and disconnects, sometimes the next time it reaches more, or sometimes the process starts again before reaching the previous percentage. In the end, it ends up synchronizing completely, but with reconnections in which the percentage gradually advances (and for that reason it takes a lot of time in comparison to syncing in one time).

To get an idea, one time it may reach 54%, the next time only 45% and the next time 60%, but it progresses little by little (the following times it will be faster to reach 60% and reach 63% before disconnecting, to give an example. I imagine it reaches 60% faster, in this example, because it has managed to send some information to the phone even if it is not fully synchronized) until it reaches 100%.
As I said it looks like it’s because the app disconnects from the device.

I’ve already tried to unlink the Flipper Zero, forget all Bluetooth devices on the Flipper Zero, reinstall the app completely and start again.
I’m on iOS 16.2

Thank you in advance for your help.

Hello again.

I think it’s solved for now. I will keep testing it the following days.
For those of you who have the same problem, I will tell you what I have done (keep in mind that this is all the process I have done and now the synchronization is working as expected, but as I don’t exactly know what I’ve done to fix it, as I’ve said, I will tell you all the process):

On my main device (iOS 16.2):

  • I have deleted the device from Bluetooth settings
  • I have deleted the app from settings: Settings > General > iPhone Storage > Flipper > Delete app
  • I have taken my Flipper Zero and went to Settings > Bluetooth > Forget All Paired Devices

On another iPhone (iOS 16.2):

  • I have installed the app in another iPhone
  • I have paired the iPhone with the Flipper Zero app
  • I have tried the synchronization. Disconnected one time but the second time the Flipper Zero synced completely

I have done the delete process (see “On my main device” list above) on this other iPhone as I wanted to use the Flipper Zero with my main iPhone)

Again, on my main iPhone:

  • Tried on my main iPhone (had to download the Flipper app again from App Store)
  • Paired the Flipper Zero to my iPhone. Synced in one time, no disconnections

As I’ve said, I will test it two or three times more to verify that it works properly, but I think what did the trick was to re-do all the pairing process (deleting the app included), even though I’ve done it before with no luck with the sync problem.

Hope it helps to someone.