RFID writing not working at all

It doesn’t write at all. The hex is equal to the token so when flipper verify it did wrote the values are the same so flipper thinks that one of the methods to write did work while in fact it did not, it’s just that the data it’s the same so when flipper reads to see if it did write what was send the values that it read are the same it attempted to write so it thinks it did wrote…

1 Like

As it says in the screenshot, this card is either non-writeable or write-protected

Also, what @Spildit said is absolutely correct

I think the majority of problems related to this will go away when flipper is able to write to EM4305 as those are most likely the most popular 125KHz RW tag …

1 Like

Well, the most popular one by far is the T5577, to which the flipper can already write, but yeah, EM4305 are definitely on our minds

1 Like

EM4100 don’t work either

1 Like

The same thing happens to me that says, [@Spildit ] only write if it is the same hex, otherwise the message appears on the screen. the card is EM4100

EM4100 is not writable

EM4100 data can be written only to T5577 cards (and EM4305 in the future), as the EM4100 cards are read-only by design and cannot be written to.

1 Like

:cry: :cry: :cry: :cry: thx

I do have several bags of 100 units that i did get from ebay and they are very cheap and all EM4305 … Even when buying T5577 there is no certain way to know that they will not ship you EM4305 because they are just the same visualy (look the same on the outside). Mines are cleared marked as EM4305 on the bag and i can write/re-write to them with other devices like the icopy and the NCF-PM5…

Fully true.

To follow up on this …

I’M NOT AFFILIATED WITH THIS SELLER BUT … I did buy those : (leaving here for reference) - 50pcs New RFID 125KHz Writable Rewrite T5577 Keyfobs Proximity Access Tags | eBay

And they FULLY WORK !!!

Those are REAL T5577 and they look like NFC blanks. The posted pictures of the amazon listing look exactly the same as my EM4305.

Tested to write Indala and IoProx. Tested with my work access card (IoProx) and it duplicates fine, flipper writes ok and reader detect the copy as original.

Another photo (sorry for bad quality)

My advice is to avoid chips that look like EM4305 as flipper can’t yet write to those…

Furthermore if i read my empty new tags i do get this :

While i can’t get a thing out of my empty/un-written EM4305 ones (i only get data if i write to them with other tools) Flipper can READ from written EM4305 but will not get a thing from full empty ones (will keep on trying to read them).

Just a follow up, i did FORMAT my new tags with KeySy and flipper now keeps attempting to read them using both methods without managing to do so unless i do write again to the tags,

Meaning the ones i did get and mentiones were simply pre-written by the seller with that empty EM41000 value.

And this reminds me … it would be GREAT to have an option on flipper to FORMAT the cards/fobs …

I am having similar issues with these exact fobs.

I am able to write EM4100 type cards fine, but am unable to write H10301 type cards.

Do you know which type isn’t working for you?

Out of curiosity, I tried writing every format that Flipper supports. Here’s what worked with the https://www.amazon.com/dp/B07GBSP8SD fobs:

  • EM4100
  • Indala26
  • IoProxXSF
  • Viking
  • Jablotron

I saw the last post and out of curiosity attemped it myself.

With the latest version of thenon-official most popular firmware branch and the fobs from the ebay listing I did post several post ago I was able to WRITE nad re-read back a pattern of AA on ALL available formats with exception of :


All the others work out for me.

Thanks for the update! I’ve ordered a few different sets from Amazon to give this another go with different hardware. If none of them work out, I’ll check out the eBay link. I just didn’t want to wait that long for them to arrive :slight_smile:

My order of https://www.amazon.com/dp/B09QRYCTZD arrived today and I’m able to write and read back all formats except AWID, FDX-A, and Keri.

Much, much better success with these!

Maybe we should keep a running list of recommended options. I have two more orders coming tomorrow and Tuesday of different types. I’ll advise how they work out.

1 Like

Putting together a list here: Rewritable RFID blanks for Flipper Zero · GitHub

I will try later today with KeySy blanks but the “problem” might be firmware related … Also try to format your cards first prior to write Keri as Keri reads in PSK and the fact that the cards have data on it might prevent writing … Unfortunatly you will need something else to format the cards as Flipper doesn’t support it yet.

Ahhh, thanks for letting me know about that Keri quirk! I don’t have anything to format these, so I’ll have to wait to finish testing. I’ve marked Keri as unknown for now, but assume it’ll work if I’m able to format them.

I got a batch of clamshell cards today that were very performant. I updated the gist.