RFID reading no longer working

I received my flipper at the weekend and had a little play with the device as soon as I unboxed it. I was able to read an RFID card I use to access a local club fine.

Since updating the flipper to the latest version (0.61.1) I have been unable to read the same card. Is anybody else having similar issues? The card in question has no external branding or identification helpfully.

I have also tried a fob type card to no avail.

Can you please send a video of your flipper reading the card?

Thank you, here you go it does not appear that video formats are allowed on the forum.

Hmm, yes, that appears to be correctly positioned.

Do you have a PH0/PH1 screwdriver what you can take the back cover off with? There might be an issue with the contacts on the RFID board that connect to the antenna board, and re-seating the back cover should help.

Here’s the guide, but you only need to do steps 1-4

Thank you for the advice, I tried this and it does not seem to have made any difference. I’m concerned it is not a hardware nature of issue as the flipper read the card happily out of the box, it just would not after the software update.

Ok. Let’s try flashing the factory firmware (Select this DFU file in qFlipper by using the “Install from file” option) and see if it works.

Sorry, that doesn’t seem to work either :pensive:

Oh, then it’s not a software issue, I’m afraid. Can you send photos of the two pairs of contact pads on your antenna board and the two pairs of pins on the RFID board? I’ll send them to our engineers to check if there’s something wrong with them.


Yeah, it doesn’t seem to be visibly broken, so Iit looks like you’ll have to file an RMA and we’ll replace your device with a new one.

Please send an email to support@flipperdevices.com (and include a link to this thread), they’ll guide you from there

Oh and btw, maybe try first writing something to the card (from your photo it looks like a T5577 blank card) and then try reading it?

Sorry it is a card I need to continue using, I would not want to affect the data already on there without backing it up. Same with the cotag fob I have. Any other suggestions very gratefully received

Do you have access to any other devices that can read this card? If so, and if you have that card’s file saved on your flipper, you can try emulating it

I don’t have access to anything else that can read the card, I also did not have a micro SD card installed before I updated the device so I am guessing this is why the card data was not retained when I did update the flipper.

I mean, can you confirm that the card itself is working? Using it the intended way, for example.

Yes, the cards I have tried are definitely working and I have double checked them.

Then I’m afraid you’ll have to go on with an RMA