qFlipper upload Folder to Flipper

Is there to way to upload a folder though qFlipper? There did not seem to be a way to do this. It will let me download a folder from my flipper but not upload one to it. I know I can take the SD card out, then put it on there. Just seems like a bit of a inconvenience.

From what I’ve found, uploading folders appears to be a work in progress:

In the meantime, I’ve been doing the workaround you mentioned - taking out the SD card and putting it back in.

1 Like

Drag and drop a folder inside qFlipper (with the file manager tab open) to upload it.
Not being able to upload folders from the “upload” menu is the result of system file picker limitations (which usually let you choose only files or only folders).

1 Like

That did not work and I just updated qFlipper to latest release.

Please elaborate what are you doing and what your OS is.
A program log would also come in handy if there are any errors shown by qFlipper.

Just want to upload a folder of ducky scripts from windows to my flipper SD card through qflipper. When I drag a folder from the windows file manager to qflipper file manager the cursor turns into the cancel sign. I have not tried on Linux yet.

The version of qFlipper I was running this weekend let me upload folders via drag and drop, but the update I applied today no longer allows it.

There were literally no changes in terms of drag-and-drop code whatsoever.
Very strange, we will try to reproduce it.

I also have this problem. Windows 10, 64GB SD card. Flipper Zero firmware 0.62.1 build 12 Jul 2022. Looks like qFlipper is maybe version 1.1.1 judging by the tiny text in the corner.

I have a folder with either more sub-folders, or just multiple files inside, I try to drag and drop from Windows File Explorer to qFlipper, with the directory open on qFlipper for where I want the file to go, and I get the cancel sign.

I should mention that I just got my Flipper yesterday, and up until now, I’ve been able to drag and drop folders. Now, though, I can’t, and nothing has changed.

Have you tried rebooting your computer?

I’ve rebooted the computer, my Flipper Zero, unplugged the Flipper and plugged it back in, all the easy stuff.

Hello,

Just so you know, I’ve got the same issue with files and folders.

Archlinux, wayland, qflipper using the appimage. No problem with qflipper except this one.

Using drag and drop :

  • When I upload either a file or a folder, I’ve got the successful return log but the object just doesn’t got here.

    306332 [RPC] (6) Storage Write @/ext/music_player/Bloody Tears.fmf START
    306391 [RPC] (6) Storage Write @/ext/music_player/Bloody Tears.fmf SUCCESS 
    306391 [RPC] (7) Storage List @/ext/music_player START
    306463 [RPC] (7) Storage List @/ext/music_player SUCCESS
    

Using right clic → upload here…

  • Same issue with files, can’t even select a folder to upload because I can only open it.

Have tried unplugging and plugging it back, and rebooting both flipper and comp.

I think I have a similar issue here is what I did on my end:
I tried to upload fmf/rtttl files for the flipper to play.

I tried to upload a .txt file containing a rtttl song and the qFlipper logs show:
[RPC] (8) Storage Write @/ext/music_player/Theme - E.T. The Extra Terrestrial.txt START
[RPC] (8) Storage Write @/ext/music_player/Theme - E.T. The Extra Terrestrial.txt SUCCESS

however, it does not show up in the files listed (nor on qFlipper folder display nor in the flipper itself).

I thought it was the format (as it’s not fmf) but after unplugging and plugging the flipper again I managed to upload the file without changing its extension.

Then it seems that whatever upload afterwards is facing the bug.

Therefore it seems that, at least in my case, unplugging/plugging again was a suitable workaround for a given file.

a few notes if it helps troubleshooting
qFlipper 1.1.1
firmware 0.62.1
windows 10 - 19044.1826 (21H2)

Hmm I think the spaces in the name of the file might be the culprit here as well.
Any file without spaces in the filename is correctly uploaded so it seems.

Somehow…

It was the space for the file. Without space, it works.
Was ready to tell it’s not space dependant because it didn’t work with the folder without space. It works with the folder.

I haven’t even made the firmware update yet.