qFlipper not recognizing device, 2 devices on one COM port (While Bluetooth on Windows is turned ON)

Tried on multiple computers. Mounted / unmounted / reformatted SD. Can’t get updater to recognize device.

What OS do you have?
Can you please show how Flipper detects in Device Manager?
Try this https://docs.flipperzero.one/basics/firmware-update/recovery

Win10. It makes the connections sound as it recognizes it. But does not show in device manager. I tried the solution you linked earlier. It did not show in DM as DFU.

In Device Manager go to Ports (COM & LPT). Do you see it there?

I had this issue with my computer 2 days ago. If other services are occupying the same port as your Flipper, qFlipper will fail to recognize it.

In my case, COM4 was the Bluetooth serial port AND my Flipper’s port, so I turned off Bluetooth on my PC, freeing up that port and allowing mine to connect.

Same here, Windows 10 update via qFlipper bricked the device. Setting it into DFU mode didn’t work on windows, as no device showed up. I had to plug it into my mac to get it to recognize anything. I might try re-bricking my device to see if I can grab some logs

Saw this situation few times. What a strange shit windows are.


There is another possible solution that I have tested on my Windows machine.
Go to Device manager, find the respective serial port, then go to its Properties. There, select Port Settings → Advanced… and in the box saying “COM port number” select another number that is not in use. This way, it should be not necessary to turn off Bluetooth at all.

If the issue was caused by swtiching the Bluetooth on, sometimes just unplugging and re-plugging Flipper may help as well.