No databases found - Windows & Ubuntu/Linux issue

Hi Flipper Fans,

I’m updating the flipper using qFlipper, but receive a ‘Datbases Missing’ message even after successful DFU reset. I’ve tried both release & release-candidate branches, but have the msg with both.
I’ve done this on both windows & Linux (Ubuntu) and have seen lots of these errors:

[RPC] Cannot match message with id

I’ve attached the full log files. Can someone point me out on how to get the databases missing fixed?

Thx a lot!
qFlipper-20220817-161143.txt (296.2 KB)

Try removing the “Manifest” file from your SD card and repairing via DFU again

Hi Astra, thanks for the prompt reply. I don’t see any Manifest file though on my SD card? (not in /, /defaults or /os or /overlays folder)

Can you attach a screenshot of the qflipper’s main screen and the file manager with SD card’s / open?

Hi Astra,

Please find attached the requested screenshots. Hope this helps

I’m not from the tech support/flipper team but i would try a new SD card that is not full … you only have 3% of free space on your card … also is full of files that i don’t have on mine …

For reference my W0tzzelu looks like this with the latest version of Unleashed ;

That’s an SD from a raspberry pi. Please format it inside the flipper for it to work, because right now it is formatted for a RPi, not for the flipper.

Hi Just as an update:

I’ve been playing around with different partition managers & command line items on different operating systems, and have come to the conlusion my microSD card is wrecked and the internal controller has set it to read-only mode: hence I’ve not been able to format it correctly.
Will buy a new microSD and try again.

Thanks for all your help - i’m 99% sure my microSD card is corrupt/wrecked.

1 Like

Have you tried just formatting it inside the flipper via the storage menu?

Yes, that didn’t work unfortunately.

I was on the data recovery business for a long time and i can confirm that with flash memory (cards, ssd, etc) when you have problems with the memory chips like lots of “bad blocks” the majority of controllers place the cards/ssds as “read only” to allow some level of user data recovery. This is “normal” to happen with “danaged” flash based storage media so what was written here makes perfect sense for me. Just want to add that i would buy a ssd just for flipper and wouldn’t use it with other devices. Regards.