Just opened flipper today and tried to update firmware - Frozen

Im using a Mac, latest MacOS, and tried to update the firmware using qFlipper. Its stuck on 'Updating Co-Processor firmware, please wait…" for 10 minutes now. The Flipper Zero appears to be powered down. Is this normal or should I start troubleshooting using my windows laptop?

1 Like

I unplugged mine despite it telling me not to. Then I plugged it back in and launched the app again (make sure you have an SD card in there for the database to download to). The app asks if I want to repair, I said repair and it quickly went through the whole process and succeeded.

Have you tried rebooting to DFU and repairing from there?

It’s not normal. I am on Mac OS Monterrey 12.3.1 and I flashed both my flippers with no issues, the whole process took around 2 mins on both. I even didn’t have an SD card for the first one and told me I needed one and I slotted it in and it continued the process on qFlipper hours later. So something must have gone wrong.

I ran into this issue it was stuck at the updating co-processer. i did not disconnect it for the usb but i did hold down the back and the left button. it made some usb connecting sounds the i let go the back button. after that it continued the rest of the install and update. hope this works for other with this glitch.


That worked perfectly for me, thanks!

This worked for me as well!