ITHO Daalderop - 4 buttons HVAC Button (NL device)

Greetings,

I’m trying to use Flipper to work with my HVAC 4 buttons controller so I can later automate my house further. Read functionality does not work but the Read Raw and Frequency Analyzer does. Send however, does not.

As a new user I can only post 4 links so I will split this post in half.

Frequency: According to the constructor it’s 868Mhz. When I use the Analyzer I get: 868.349~868.350

Modulation: AM is the only one’s that show anything

Static or Dynamic code: Decode doesn’t work so not sure

Capturing RAW signals: I have recorded the buttons 10 times each:
RAW_4.sub (872 Bytes)
RAW_3.sub (877 Bytes)
RAW_2.sub (2.3 KB)
RAW_1.sub (791 Bytes)

URL of the device: https://www.ithodaalderop.nl/nl-NL/professional/product/536-0150
Documentation: https://ithodaalderop.compano.com/Data/Environments/000001/Attachment/Bijlage/A04_Ventilatie/A04_80_Accessoires/A04_80_01_Bedieningen/A04_80_01_01_RFT/B01_05_MAN/01-00903-008%20%20Handleiding%20RFT%20AUTO%20(nl).pdf

Photo of the inside:

Greetings …

Do your raw files work on your system ? If you replay them with flipper do they work ?

If so can you provide a description of what each button do and a raw of a single press of each button ? This is just personal curiosity as i would like to add to my library a copy of your remote just in case it does work with similar HVAC systems.

Thanks.

Hi @Spildit Unfortunately they do not work - Thus why I’m posting :smiley:.

The full detail of the button can be found in the technical documentation here page 2 https://ithodaalderop.compano.com/Data/Environments/000001/Attachment/Bijlage/A04_Ventilatie/A04_80_Accessoires/A04_80_01_Bedieningen/A04_80_01_01_RFT/B01_05_MAN/01-00903-008%20%20Handleiding%20RFT%20AUTO%20(nl).pdf - I know it’s in dutch (google translate camera works well) but in essence:

  • Automatic mode with 3 position 1st mode depending on CO2 level / Relative Humidity - person detection night/day and nightime
  • Low Setting
  • High Setting
  • Timer 10 min each click of the button for max of 30 min

Ok …
Flipper team can only implement parsers so that the READ will decode your data if the RAW do work/is correctly collected.
If your RAW capture doesn’t work then the data on the RAW files is of no use to the flipper team.
You might be capturing on the wrong modultaion. You have to figure out by the use of SDR for example the exact modulation/frequency and if applyable the deviation so that you will end up with working signal/raws when you do a raw capture.
The READ implementation only serves to parse the packets and decode them on “visible” data, if the read raw isn’t working there is no “magic way” to make READ work as READ is just a decoded/parsed form of the data captured in RAW …

This might be helpful:

And:

YES, this is simply excellent stuff! but the authors there have done such a thing without a bottle to figure it out, and for this I need such a remote control for experimenters, without it I think it will be difficult. since the sequence of pressing the buttons matters, it seems to transmit with different deviations, different byte lengths … in one word without a remote control it will be difficult. And how common is this system?

setting

  • FREQ2, FREQ1, FREQ0 = 868,299865 MHz
  • MDMCFG4, MDMCFG3 = 4004,47845458984375 baud
  • MDMCFG2, MDMCFG1, MDMCFG0
    • MOD_FORMAT = 2-FSK
    • MANCHESTER_EN = Disable
    • SYNC_MODE = No preamble/sync word
  • CHANNR = 0
  • DEVIATN = 25,390625 KHz
  • FREND0
    • LODIV_BUF_CURRENT_TX = 2
    • PA_POWER = 7
  • MCSM0
    • FS_AUTOCAL = Automatically calibrate when going from TX back to IDLE
    • PO_TIMEOUT = 64

Is that a saying? If so where is it from? I love it.

Anyways, I’ve read it since I’m interested in it as well (and have a similar system) and it seems a bit over-engineered for such a system. As far as I know it’s a pretty common system in the Netherlands.

I’m going to ask Original Poster to do the following :

  • ADD 868299865 frequency to subghz config file on SD card.
    -ADD this pre-set :

#2-FSK 200khz BW / 135kHz Filter/ 25.39Khz Deviation + Ramping
Custom_preset_name: FSK25k
Custom_preset_module: CC1101
Custom_preset_data: 02 0D 03 47 08 32 0B 06 15 40 14 00 13 00 12 00 11 32 10 A7 18 18 19 1D 1D 92 1C 00 1B 04 20 FB 22 17 21 B6 00 00 00 12 0E 34 60 C5 C1 C0

Try to capture again using the added frequency and pre-set/modulation. Check if the files do operate the ITHO when replayed…

Hi Spildit,

I got my Flipper last week and followed your instructions above. Unfortunately, it didn’t work.
Any ideas on what to do next? Can you give me a pointer where I can find more information on how you derived those settings? Maybe I can fit them to work.

Michiel

To add some more info:

Not sure if this helps.

I also know there is a join procedure where you need to remove power from the fan unite and then in the first 2 minutes i believe you are able to add a new remote but maybe there are ways around this.