Github Android App

The app is not fetching nor the zip is building:

23:58:17.527: [..\..\..\..\Projects] git -c core.quotepath=false -c log.showSignature=false clone --progress --recurse-submodules https://github.com/halxinate/Flipper-Android-App.git -- Flipper-Android-App
Cloning into 'Flipper-Android-App'...
remote: Enumerating objects: 9328, done.        
remote: Counting objects:   0% (1/3694)        
...   
remote: Counting objects: 100% (3694/3694)        
remote: Counting objects: 100% (3694/3694), done.        
remote: Compressing objects:   0% (1/1934)        
remote: Compressing objects:   1% (20/1934)        
...     
remote: Compressing objects: 100% (1934/1934)        
remote: Compressing objects: 100% (1934/1934), done.        
Receiving objects:   0% (1/9328)
Receiving objects:   1% (94/9328)
...
Receiving objects:  99% (9235/9328)
remote: Total 9328 (delta 1630), reused 2340 (delta 1034), pack-reused 5634        
Receiving objects: 100% (9328/9328)
Receiving objects: 100% (9328/9328), 2.57 MiB | 11.29 MiB/s, done.
Resolving deltas:   0% (0/2814)
Resolving deltas:   1% (44/2814)
...
Resolving deltas: 100% (2814/2814), done.
Submodule 'components/bridge/protobuf/flipperzero-protobuf' (git@github.com:flipperdevices/flipperzero-protobuf.git) registered for path 'components/bridge/protobuf/flipperzero-protobuf'
Cloning into 'C:/Android/Projects/Flipper-Android-App/components/bridge/protobuf/flipperzero-protobuf'...
Warning: Permanently added the ECDSA host key for IP address '192.30.255.112' to the list of known hosts.
git@github.com: Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.
fatal: clone of 'git@github.com:flipperdevices/flipperzero-protobuf.git' into submodule path 'C:/Android/Projects/Flipper-Android-App/components/bridge/protobuf/flipperzero-protobuf' failed
Failed to clone 'components/bridge/protobuf/flipperzero-protobuf'. Retry scheduled
Cloning into 'C:/Android/Projects/Flipper-Android-App/components/bridge/protobuf/flipperzero-protobuf'...
git@github.com: Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.
fatal: clone of 'git@github.com:flipperdevices/flipperzero-protobuf.git' into submodule path 'C:/Android/Projects/Flipper-Android-App/components/bridge/protobuf/flipperzero-protobuf' failed
Failed to clone 'components/bridge/protobuf/flipperzero-protobuf' a second time, aborting

Any pointers? Knowing you are at war, I’m skeptical you’ll fix the apk for my S8 any time soon.
How to build it?

Why not use version from Play Market?

As I see it, the person wants to build an application, not use our build. Perhaps for research and modification.

@halxinate try clone via ssh, please
Also you always can found builded apks here: Releases · flipperdevices/Flipper-Android-App · GitHub

Correct. Because posted on Github releases does not work for me for an obscure reason (app failing to start on 3 phones) and I cannot find your app on PlayStore, which usually means none of my Android phones compatible, despite you are having minSdk = 21 in the config and all my phones being API 26 - 28.

I can only speculate that’s the new BT_SCAN_something (iirc API 29 and above only) feature which the app requesting might be hiding it from my phones on the Store. Unless you’ve chosen an obscure name for the app, as my search for “flipper zero”, “flipper app”, just “flipper” returns nothing relevant (there is no single link on your websites to that app either, by the way).

That’s why I have to spend my precious time building your code to figure out what’s wrong with it but could not as it looks poorly organized having the proto package probably “symlinked” in the git repo (never used that feature). It’s not fetching that symlink due to the public key Github issuing for the Android Studio. You should put a note that the user have to manually copy the missing folder content from the flipperzero-protobuf repo or actually embed it into the main repo. After that I’ve been able building it (for the emulator so far).

I cannot find your app on PlayStore

The app has not yet been published on Google Play, this will be done this week.

building your code

Why did you build the app when I attached the link to download the app above? Have you tried downloading from there?

Hey, Lion. Because I’ve tried three of them before asking here. No go (they are installing but either crashing right after the launch or not launching at all).

No worries, I’ve managed to build it for my S8 and Zfold2 just fine today (see my note about the proto above).

It looks like Pavel didn’t know the app is not in the Play Store yet? :slight_smile:

This is NOT okay. Do you have any way to tell me what’s going on or send logs? Perhaps recording a video might help me.

The app was previously published, but is now hidden so that users do not use the untested app. It will be released and published this week!

I’ve explained what’s going on and what might be a culprit twice above.
Do you have a dedicated crash logging facility in the app?
Have you tested on Samsungs and API 23-28 devices?

On API 23-28 yes, on samsung yes. But not on your model.

Meanwhile, found a severe bug in the dev branch:

  1. Running the app from AS (debug flavor).
  2. Had my flipper connected to z2 yesterday just fine. Everything been working OK including experiments.
  3. Disabled BT on Z2, connected from S8. Z2 powered off. All good too.
  4. Disabled BT on Flipper to conserve power overnight.
  5. Today, launched the app on S8 directly (no AS supervision).
  6. Got the message “Binding device invalid … something … forget the device … something”.
  7. OK, BT on the Flipper was off. Turned it on.
  8. The bug: no matter what I do now, including unpairing the device on the S8 (as probably instructed in a wrong wording in that very quick to comprehend toast), the app is not connecting back.
2 Likes

Took this bug to work. I’ll report here as progress. Thank you!

One more update:
I’ve figured that “Forget” in that toast message might be about the Flipper, not the phone (as there is a “Forget all paired devices” menu item in BT settings there). Tried that as well. But the issue persists. So I have no pairings on the Flipper, no paired flipper on the phone, but the app cannot connect anyway.

I bet it’s a combination of issues on the Flipper and in the app not being able to agree on something.

At the minimum, please extend the toast duration so people could read the message, and improve the message so it’s clear where, what, and how to “forget” (better replace these toasts to a fair windowed UI with the OK confirmation, as some folks can read fast, some not, some will need time to make a screenshot for you for troubleshooting). Android Toast must be considered a single word feedback tool only. And primarily used as a developer’s visual debug tool nowadays.

Perhaps, it’s better filing bugs on Github?

Yeah, the app isn’t finished yet :slight_smile: That’s what it’s used for.