Firmware update fails?

I just got a flipper in the mail yesterday. Today I tried to update the firmware by going to Flipper Zero Firmware Update via qFlipper, installing and running qflipper, and running update from local file. I thne select 0.50.0 firmware file and I get “Failed to reboot the device: Reconnect timeout exceeded.” The flipper than gets stuck in recvoer mode with DFU started.

Is there some step I’m missing?

1 Like

Use google translate to be able to read this the extension in your browser works good to translate the whole page.

UPDATE: There is english version

You need to install an SD card before doing the install. I did the exact same thing on first getting mine. Tried updating with no SD and it took forever. Then I read some directions and realized what I did wrong. So I unplugged, dropped a microSD card into slot, plugged it into the USB port, and relaunched qFlipper. It immediately detected a busted firmware upgrade and the options led right to a solution.

1 Like

Can’t get mine to update. Even with a SD installed. Tried reformatting and unmounting. Still won’t install. The usb works, as it does charge via the PC.

My problem was that I had downloaded the .zip file for qflipper instead of the .exe file, and I wasn’t able to get the full qflipper program running until I downloaded the .exe file.

@randybingo the above linked guide was very useful for me. I did have to put one into DFU mode (by holding enter and back for 30 seconds) to get it to work.

now its just bricked

I was surprised that several times mine seemed bricked but came back to life eventually. I think what looks like being bricked might just be the DFU mode.


  1. Why do you update from local file? Just press the green UPDATE button. Also you can choose the update channel in qFlipper settings between dev, release and rc.

  2. Can you please show the full log with error?

You can always restore firmware using this method

1 Like

as I mentioned elsewhere, my problem was I downloaded the qflipper .zip files, and then couldn’t figure out how to run qflipper correct. There’s a qflipper.exe file in there that only has the install locally option. But once I installed the .exe file I no longer had to to the local file thingy.

What? Please use this version Flipper Zero Firmware Update via qFlipper

Thank you! Didn’t realize the same process brings it back out. Still can’t get it to upgrade in qflipper unfortunately.

dude my problems have been solved please save your services for someone more in need.

This is resolved, I did what I wasn’t supposed to do and I unplugged it, and plugged it back in. That finished the update and now it works :wink: Thanks!