DFU repair failed


Today I have received my Flipper zero. I wanted to update the firmware but it finished with error.

[RCY] Correct Option Bytes @Silwore ERROR: Failed to write corrected option bytes: Operation timeout
[DEV] Full Repair @Silwore ERROR: Failed to write corrected option bytes: Operation timeout

The device is stuck with only green led lit and I can only reboot it to DFU.

The very same error happens on OSX and Windows 10.
Please advise.


qFlipper-20221208-173438.txt (21.2 KB)

I forgot to mention that the primary reason for fw update was that the device could not read two different SD cards… Maybe there is an HW issue and it resulted in bricked device?

Hello! What SD cards have you tried using? If they’re not SanDisk, Kingston or Samsung, they might not work, as many smaller manufacturers leave out the SPI communication protocol that we use.

Can you try taking the SD card out and following this guide? Firmware recovery - Flipper Zero — Documentation


I have already tried different SD cards (Kingston, Samsung, SanDisk). The problem persists, the restore procedure does not work and always ends with error (logs in OP).
Please advise.


Hello, sorry for the late answer. After more research on your log file, it seems that your device was disconnected during a critical part of the update process, and that caused it to have incorrect Option Bytes set.

Can you please re-try doing the DFU recovery with the SD card removed, record the video of you doing it (helps catch parts of the process you might have accidentally missed), and if it fails - attach the log file here again?