Cannot connect flipper FW 0.69.1 to android app v1.2.2

I got the flipper zero today, updated FW to 0.69.1 via desktop client and installed the Flipper mobile app v1.2.2 via GooglePlay to my android smartphone (Honor 20 View, Android 10). Smart-to-flipper connection via BT looks correct (phone shown device, asks for key, flipper shows key, mobile app accepts it), but then mobile app reports “Outdated firmware version” and doesn’t communicate with flipper more. Flipper reboot, flipper FW re-installation, mobile app delete/reinstall and smartphone reboot don’t help. Meanwhile, linux desktop application works with my flipper well.

P.S. Android app shows “can’t find version gatt service”

Oh, this looks like a problem on the wrong side of the phone: software or hardware.
Please answer the following questions:

  1. Do you have other BLE devices connected? Which ones? Do you have any Bluetooth device connected at the time of connection?
  2. What phone model is it?
  3. What firmware you have on your phone? Are you using official firmware?
  1. I have other BLE devices connected to the phone (e.g. wireless earphones or Nordic NRF52 devboard)
  2. Phone model is Honor View 20 by Huawei, android 10
  3. Phone FW is official, not rooted.

Please, show screenshot from this application with connected flipper:



1 Like

Which version of Android?

10

Had the same issue. Fixed it by shutting down all other BLE devices and re-establishing connection with Flipper through Android OS menu (also I marked option that pin has numbers &/ letters, which I wasn’t done before)

My phone is Xiaomi Mi 9T Pro with MIUI 12.5.2

Had a similar problem, albeit with a different error message. The fix in my case was to allow the flipper app to use bluetooth in Android Settings > Apps > Flipper > Permissions > Nearby Devices > Allow. It had been shut off after a certain amount of time (a few months, give or take).