Another apparently bricked Flipper - Is mine for reals?

So I think my Flipper is bricked. I ran qFlipper and it updated itself (yay), and then started to update my Flipper’s firmware to the latest and greatest. Then, it said it failed and I looked down to see a blank screen and a rapidly flashing red LED on the Flipper. After waiting about 5 minutes to make sure it wasn’t going to do something, I unplugged it. Now it won’t boot and I can’t get it into DFU mode to do a firmware recovery. Here are the logs from that session: qFlipper_FailedFirmwareUpdate -

For reference, the cables I’ve tried on the original computer were both USB-A to USB-C cables. There was a formatted SD card in the slot, and I’ve successfully updated the firmware once previously (when I first received the device). There are no hubs or other devices between the Flipper and my computer.

I have tried multiple times to enter DFU mode according to the instructions at the firmware-recovery page reference in previous “bricked” posts.

I’ve held down the OK and Back buttons for 30 seconds, 35/40/45/60+ seconds, with no luck. The Flipper is fully charged (it was when I started the process, and I’ve got a charger that indicates the voltage and current passing to the device, which eventually stops sending anything to the Flipper, after starting at about 3W of power output).

Holding LEFT + BACK for 30+ seconds got it back to the rapidly flashing red LED state, but the DFU mode button sequence kills that right off the bat and still doesn’t get me into DFU mode. At least the Flipper is semi-responsive. The alternate recovery sequence (LEFT + BACK then release BACK, as shown on the basics>reboot section of the docs) doesn’t do anything either (there’s never a blue LED, just the red flashing one. Also, the screen remains dark).

I’ve also tried using a USB-C to USB-C cable directly with my Windows laptop as well, but there is no indication that the USB port is ever responsive on the Flipper, regardless of the prescribed button combinations and cable/computer combinations.

The only thing I can do with any consistency is to get the red LED to flash rapidly. What are my next options?

Oh, that sounds bad, but it might be recoverable. Please ping skotopes#4130 in discord, he should be able to help you.